home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-python / pyparted-1.6.9-r1 / pyparted-1.6.9-r1.ebuild < prev    next >
Text File  |  2006-04-25  |  1KB  |  43 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.9-r1.ebuild,v 1.7 2006/04/01 18:48:01 agriffis Exp $
  4.  
  5. RH_EXTRAVERSION="3"
  6.  
  7. inherit eutils rpm flag-o-matic
  8.  
  9. DESCRIPTION="Python bindings for parted"
  10. HOMEPAGE="http://fedora.redhat.com"
  11. SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/${P}-${RH_EXTRAVERSION}.src.rpm"
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="amd64 hppa ~ia64 ppc sparc x86"
  15. IUSE=""
  16.  
  17. # Needed to build...
  18. DEPEND="=dev-lang/python-2.4*
  19.     >=sys-apps/parted-1.6.9"
  20.  
  21. src_unpack() {
  22.     rpm_src_unpack
  23. }
  24.  
  25. src_compile() {
  26.     cd ${S}
  27.  
  28.     # -fPIC needed for compilation on amd64, applied globally as only one shared
  29.     # lib is produced by this package.
  30.     append-flags -fPIC
  31.  
  32.     # This is needed otherwise it won't build
  33.     # If anyone wants to figure out why... go ahead!
  34.     export LDFLAGS="-ldl"
  35.     econf || die
  36.     emake || die
  37. }
  38.  
  39. src_install () {
  40.     einstall || die "Install failed!"
  41.     dodoc AUTHORS COPYING README ChangeLog
  42. }
  43.